TV-Lite Community

Author Topic: Video Playback In Linux Web Browsers SUCKS!  (Read 89 times)

Offline octavian

  • Newbie
  • *
  • Posts: 2
    • View Profile

Offline Cristian

  • Global Moderator
  • Newbie
  • *****
  • Posts: 18
  • TV-Lite developer
    • View Profile
    • TV-Lite
Re: Video Playback In Linux Web Browsers SUCKS!
« Reply #1 on: October 05, 2021, 01:38:47 »
Nu am avut probleme niciodata din cauza asta. În Chrome se pot activa flag-urile pentru accelerare video relativ simplu, cred că și în Firefox la fel, chiar video-ul ăsta pe de pe Youtube l-am vazut 1080p 60 Hz cu proccesorul undeva la 50%, fără ca imaginea să sacadeze. Problema e totusi critică pentru procesoarele de dinainte de 2012.

Offline octavian

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Video Playback In Linux Web Browsers SUCKS!
« Reply #2 on: October 06, 2021, 15:35:13 »
Imi place să mă uit la clipuri video pe Youtube, normal mai ales despre GNU/Linux și am vazut in timp postări ale omului ăsta unde vorbea bine și elaborat despre SO Linux, Cand am văzut că la un video zice SUCKS am vrut să trec mai departe dar apoi curios am deschis clipul....el vorbea foarte serios și-am zis ”de atata timp eu văd rău și zic că-i bine” cu toate că....sincer nu vedeam unde-i SUCKS...N-am chrome, eu sunt cu vivaldi si am firefox oferit generos by default. Cand am cerut ”send to mpv” s-a deschis in player clipul dar in continuare nu vedeam unde-i sucks...Am vrut să impart cu colegii de forum că deh!!!...avem forum(mulțumesc frumos!!!...) poate că totusi poate fi de folos informația din clip

Offline Cristian

  • Global Moderator
  • Newbie
  • *****
  • Posts: 18
  • TV-Lite developer
    • View Profile
    • TV-Lite
Re: Video Playback In Linux Web Browsers SUCKS!
« Reply #3 on: October 10, 2021, 01:55:28 »
Tipul are dreptate (sort of)
Este foarte adevărat, browserele au avut intotdeauna probleme cu asta. Din motive de cum e structurat Xorg. Acum vreo 10 ani, nu puteai visa la accelerare video în browsere pe Linux, pentru că era "sort of different beast". Impresia mea e ca in ziua de azi lucrurile s-au  mai aranjat, dar asta probabil datorita procesoarelor.
Prin 2008-2009 încă mai aveam calculatoare vechi, de la începutul anilor 2000. Cu câte o placa video de atunci, cu cate un singur nucleu, ceva gen Pentium 4 sau AMD Sempron. Țin foarte bine minte că puteam vedea cu astea filme în playere gen VLC sau MPlayer, fără probleme. Clipurile de pe Youtube, însă erau jale. Ajunsesem să descarc câte un clip de pe Youtube, numai pentru a-l putea vedea în Mplayer sau Xine ca lumea.
Dar, o dată cu noile procesoare, lucrurile astea par că s-au rezolvat. Poate omul are dreptate și decalajul se menține. Dar, la ce PC-uri avem azi, problema cred ca apare de la 4k în sus. La mine si 720p e mult...